Welcome to the Australian Ford Forums forum.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and inserts advertising. By joining our free community you will have access to post topics, communicate privately with other members, respond to polls, upload content and access many other special features without post based advertising banners. Registration is simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact us.

Please Note: All new registrations go through a manual approval queue to keep spammers out. This is checked twice each day so there will be a delay before your registration is activated.

Go Back   Australian Ford Forums > Ford Australia Vehicles > Small and Mid Sized Cars > Mondeo

Reply
 
Thread Tools Display Modes
Old 18-11-2018, 02:21 PM   #1
Mackspower
Regular Member
 
Join Date: Feb 2011
Posts: 119
Post SOLVED: Poor AM Radio Reception

I wanted to share at least one fix for poor AM Radio reception.

Judging by the number of hits I got on google and forum searches . . . this is a relatively common issue for later model Mondeos.

In my case - the cause was poor connections on the AM/FM antenna amplifier.
This amplifier is located under a plastic pull-off panel on the top interior of the hatch door (boot lid). In my case there where two separate issues:

1. The phantom power connector (+12V) was barely holding on (I assume this works loose due to the percussive impact of closing the hatch over many years)
2. The bolted earth connection was not clean

I have highlighted the two connectors in the attached picture. I cleaned them both with 600 wet-and-dry sandpaper and wiped clean with isopropyl alcohol. In the case of the bolted connection - clean the bolt AND the tab from the amplifier unit. Be thorough. I avoid using contact cleaners these days but use whatever cleaning agent you trust.

AM reception has returned to full strength. Night and Day difference.

Hope this helps someone . . . share your experiences.
Attached Images
File Type: jpg Mondeo-AM-FM-Reception-Notate.jpg (133.8 KB, 58 views)

Last edited by Mackspower; 18-11-2018 at 02:27 PM. Reason: edit: spelling :-)
Mackspower is offline   Reply With Quote Multi-Quote with this Post
6 users like this post:
Reply

Thread Tools
Display Modes

Forum Jump


All times are GMT +11. The time now is 06:43 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Other than what is legally copyrighted by the respective owners, this site is copyright www.fordforums.com.au
Positive SSL